Sign in

Unstable issue of Polyphone 2.0.1

  • YA 5 0
    Message from yarajii on
    Hi there,
    I'm just a beginner of both Polyphone and soundfont in a month. I really like Polyphone, design of it and especially audition tone played by virtual keyboard is emulated more than Viena. As I have still many uncertainty things, I'd appreciate for a great advice.

    -To lose file access (crashed?) : I still don't know the detail cause of this though, it sometime loses access to source sf2 file.
    This happens often when play keyboard and adjusting parameters, again and again. Suddenly I notice no reflection to test sound by changing parameters. In such case, re-selecting other Instruments/Presets doesn't work, like the main window is frozen, and test sound also no move to other.
    -It sometime happens without virtual keyboard opened.
    -It could be back by re-opening the sf2 file, sometime.
    Currently, I am always saving file even a single parameter change. If Polyphone is surviving, another parameter change gives Save icon activated.

    Environments:
    -600MB for GS (520MB PF) ... too big for one sf2 file?
    -Win-7Pro SP1, x64, 8GB, Realtek/ASIO*
    *In case of ASIO output, I have to terminate the polyphone process in Windows device manager, if the symptom happened. Otherwise he loses sound output.
    -Polyphone 2.0.1 buff size : 1024 If the buff size is smaller, it gets to be unstable.
    -Parameters of Instruments(in General) : 62465
    -Parameters of Presets(in General) : 19839

    Thanks and Cheers,
  • Sy 70 0
    Message from Sylvia on 1
    Hello Yarajii,

    Welcome to the world of SoundFont creation!

    Firstly, I'm going to attempt to describe what's happening:

    1. You open a SoundFont's instrument/preset data and you change a value.
    2. When you open the piano keyboard to test your changes, the change is not reflected in the sound.
    3. After this intriguing thing happens, you go onto another instrument/preset, but the main part of the display does not change to the new instrument/preset, it stays on the old instrument/preset.
    4. Thinking that there is something wrong, you save the SoundFont, but the changes are not reflected in the saved file.
    5. After re-opening the SoundFont, the issue seems temporarily fixed, until it happens again.

    I have been able to reproduce this bug/behaviour on Windows 10 Home, but I am not able to confirm because my Win10 machine's hard disk has died. I haven't tested it on my Ubuntu machine, but I will do so in the near future.

    Thanks,

    Strix.
  • YA 5 0
    Message from yarajii on
    Hello Strix,

    Thanks for your welcome message and some info concern about OS dependency. I realized that Linux must be more stable, I should move on that way, maybe.
    Your description was perfect, and appreciated you could understand the issue well. Indeed, I'm in trouble now, even without piano keyboard opened. Trying re-open the file, rebooting Polyphone, or edit other instruments without intention.
    Although I reported a case of ASIO driver issue, it is used via ASIO4All. Because native ASIO (Roland) driver could not be recognized by Polyphone, but it is rerouting to Windows DirectSound. I guess Polyphone cannot kill process in Windows go through ASIO4All.

    Thanks,

    yarajii
  • Sy 70 0
    Message from Sylvia on
    Hello Yarajii,

    I have not been able to reproduce the issue on my Ubuntu Eoan Ermine (development branch) machine. I have tried to set as many parameters as I can but Polyphone remained responsive throughout the testing.

    Guess it is an issue with Windows only.

    Anyway, is reopening Polyphone no longer fixing the issue?

    Thanks,

    Strix.
  • YA 5 0
    Message from yarajii on 1
    Hello Strix,

    I appreciate your deep kindness to care about me!!
    The situation of Polyphone on Win-7 is also changed depend on a boot timing. Sometime stable in longer. It might have something collisions of other processes. I will continue to investigate on it, such as kill other audio process, screen saver, so on, because it is still not a commercial business right now, on the way of learning soundfont skills.
    If a serious business would start, I will move on to Ubuntu what you are using.

    If I get a hint on this issue, I will post a message later days.

    Thanks,

    yarajii
  • ZI 176 0
    Yes, This was happen many times.
    That's why I went back to 1.9.

    OS: Win10
  • YA 5 0
    Message from yarajii on
    Hello ziyametedemircan,

    It is also a great info of your detail version management.
    I will try older one!!

    Thanx,

    yarajii
  • Sy 70 0
    Message from Sylvia on
    Update on this:

    When I tried to edit a soundfont, I have gotten the same issue now on Ubuntu. So therefore ubuntu has the glitch as well. However, Ubuntu does not glitch after just one parameter; it takes many more parameters to glitch Polyphone on Ubuntu.

    Please fix.

    Strix.
  • 408 0
    Message from Davy on
    Hello this bug is major. I create the issue on Github, it needs to be fixed for the stable release 2.1
  • Message from Davy on
    Is it possible for someone to test with the beta version 2.1? It's been 15 minutes I'm changing the parameters but everything is still working!
    https://www.polyphone.io/o/en/files/6-po…8-polyphone-2-1-beta
  • YA 5 0
    Message from yarajii on 1
    Hi Davy,

    It may not be a enough test as I am running on other job, I confirmed the bug seems to have been fixed. The conditions are,
    -Windows 7 SP1 Japanese version
    -Realtek HD audio and Roland UA-4FX (checked with only Windows Direct Sound driver)
    *tested about 20min operation.

    I am happy with this result, appreciated your great job and congratulations!!

    Thanks and regards,
  • 408 0
    Message from Davy on
    Thank you very much!
    Now that I'm thinking of this bug, I remember that I discovered it. I was editing an instrument and when I clicked on the tree nothing happened. So it would be logical that I fixed it.

    Regards,
    Davy
  • ZI 176 0
    [2.1] Yesterday, the same situation happened to me twice in the sample area.
    Software become dysfunctional with a permanent window that cannot be changed.
    It doesn't matter if you click on another sample, Instrument area, preset area, menu area or another places.
    The only solution is to quit the software and re-launch.
  • 408 0
    Message from Davy on
    Do you remember if you did something special? I cannot reproduce the bug.
    Davy
  • ZI 176 0
    Actually, I know.
    But I couldn't find the order in which this bug was triggered.

    More or less the situation is:

    • One sf2 soundfont is open in the first tab. I'm in the samples section. And a sample is selected. I see the sample's wave window.

    • One sfz soundfont is on the other tab, I copied two samples from there (from samples section). And I switched to the first tab and pasted it.

    ...
    By the way, I did a couple of operations with mouse, but I don't remember what I'm doing.
    ...

    As a result, I stayed in the window of the first selected sample.
  • Maybe it has nothing to do with opened soundfonts or copy-pasting operations.
    Because I've tried several combinations and I've failed to repeat the same bug.

    I think that my actions with the mouse might have triggered this Bug.

    I tried so hard to remember.
    But since I do a lot of things automatically, I guess I never paid attention to this part.
  • This bug occurred again after pasting many samples.

    My procedure is:
    I started the Polyphone software,
    selected a soundfont from list,
    then dropped files from the folder to the soundfont. (601pcs)
    bugbug.gif
  • 408 0
    Message from Davy on
    Do you think it can come with the wave display when you switch to a sample? It produced a freeze on Mac, it just fixed it. Maybe it could have done the same bug on Windows or Linux.

Sign in or register to take part in discussions.

Polyphone needs you!

Polyphone is free but there are costs associated with its website and development. A small donation will help a lot.

Donate
Learn the basics Try a tutorial
Scroll to
top